Topics

Screen fills with ^@^@^@^@^@^@.... when running inside emacs


intertricity@...
 

Hey there, been trying to track down and troubleshoot this behaviour. I'm using Kubuntu 19.10. I created a script to start mono:

#!/bin/bash
mono ipy.exe

To run ironpython as a single command for emacs using "comint-run" to hopefully interact with whole functions and lines between emacs and the buffer interactively. https://www.emacswiki.org/emacs/ComintMode

The problem is the screen displays the prompt ">>>" but right after, the screen fills non stop with the ^@ character, so I get lines and lines of ^@^@^@^@^@^@^@^@^@

I think this may be the Ctrl-@ null character, I'm not sure. I could probably filter it out, but I was hoping to get some insight into this issue, if its something I should do to the IronPython source, or if I should just filter it out on the emacs side. Any help is appreciated!


Stéphane Lozier
 

The screen fills with ^@ when you run your start script from bash or with "comint-run"? Which version are you running? Are you using the .deb package?

On Fri, Dec 27, 2019 at 8:13 AM <intertricity@...> wrote:
Hey there, been trying to track down and troubleshoot this behaviour. I'm using Kubuntu 19.10. I created a script to start mono:

#!/bin/bash
mono ipy.exe

To run ironpython as a single command for emacs using "comint-run" to hopefully interact with whole functions and lines between emacs and the buffer interactively. https://www.emacswiki.org/emacs/ComintMode

The problem is the screen displays the prompt ">>>" but right after, the screen fills non stop with the ^@ character, so I get lines and lines of ^@^@^@^@^@^@^@^@^@

I think this may be the Ctrl-@ null character, I'm not sure. I could probably filter it out, but I was hoping to get some insight into this issue, if its something I should do to the IronPython source, or if I should just filter it out on the emacs side. Any help is appreciated!