Speech Recognition inside Grasshopper for Rhino

psf@...
 

Hey everyone,

I was hoping to maybe get some pointers. I’m trying to implement speech recognition using python inside rhino\grasshopper, which in turn relies on IronPython (2.7.8) as its platform.

So far I’ve managed to install SpeechRecognition 3.8.1 but this depends on PyAudio which is making all the trouble.

 

The error  I’m getting is: Python was built with Visual Studio version 6, and extensions need to be built with the same version of the compiler, but it isn't installed.

Do I need to get Visual Studio version 6 or is the some other compiler I can use, that will do the trick. (I’m on Windows 10 and have Visual Studio 2017)

 

Best

Povl

 

 

Full error message :

C:\IronPython 2.7>ipy -X:Frames -m pip install PyAudio-0.2.11.tar.gz

 

Processing c:\ironpython 2.7\pyaudio-0.2.11.tar.gz

Installing collected packages: PyAudio

  Running setup.py install for PyAudio ... error

    Complete output from command "C:\IronPython 2.7\ipy.exe" -u -c "import setuptools, tokenize;__file__='c:\\users\\xyz\\appdata\\local\\temp\\pip-earp3s-build\\setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record c:\users\xyz\appdata\local\temp\pip-v4gaeb-record\install-record.txt --single-version-externally-managed --compile:

    running install

    running build

    running build_py

    creating build

    creating build\lib.cli-2.7

    copying src\pyaudio.py -> build\lib.cli-2.7

    warning: build_py: byte-compiling is disabled, skipping.

 

    running build_ext

    building '_portaudio' extension

    error: Python was built with Visual Studio version 6, and extensions need to be built with the same version of the compiler, but it isn't installed.

 

    ----------------------------------------

Command ""C:\IronPython 2.7\ipy.exe" -u -c "import setuptools, tokenize;__file__='c:\\users\\xyz\\appdata\\local\\temp\\pip-earp3s-build\\setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record c:\users\xyz\appdata\local\temp\pip-v4gaeb-record\install-record.txt --single-version-externally-managed --compile" failed with error code 1 in c:\users\xyz\appdata\local\temp\pip-earp3s-build\

 

You are using pip version 8.1.1, however version 19.2.3 is available.

You should consider upgrading via the 'python -m pip install --upgrade pip' command.


Povl Filip Sonne-Frederiksen
Research Assistant
Cand.arch.
Logo
T: +45 8936 0000
E: psf@...
W: aarch.dk
Tagline

Join users@ironpython.groups.io to automatically receive all group messages.